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Overview — TA0013

This Arduino Uno ultimate project kit includes comprehensive range of components to get you started
in building and experimenting with Arduino projects. The “RFID Starter Kit for Arduino Uno” comes
in a handy case and contains over 30 state-of-the-art components, devices and modules. This is a
huge value starter kit includes lots of common electronic components and module; Uno development
board, LED's, resistors, sensors, LED displays, RFID readers, relays, stepper motors and more. For
complete package list, please refer to our website.

The wide range of peripherals included in the kit ensures the number of different experiments and
applications you can build.

In this instruction, we will walk through IR remote + the receiver, and MFRC522 13.56Mhz IC by
MIFARE, as described at:

- https://www.auselectronicsdirect.com.au/arduino-rfid-uno-starter-kit

If you would like to purchase additional RFID cards of fobs they can be found at the following:

- https://www.auselectronicsdirect.com.au/arduino-rfid-read-and-write-module-kit

Let’s get started!
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RFID Fundamentals

RFID stands for: Radio Frequency ldentification

RFID, or Radio Frequency Identification, is a system for transferring data over short distances
(typically less than 6 inches). Often only one of the two devices need to be powered, while the other is
a passive device. This allows for easy use in such things as credit cards, key fobs, and pet collars as
there is no need to worry about battery life. The downside is that the reader and the information holder
(ie credit card) must be very close, and can only hold small amounts of data.
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Each tag has a unique 1D number that is read from the sensor and a microcontroller takes it from
there. RFID cards/tags cannot hold data like a card with a magnetic strip, such as a metro card which
keeps track of when it expires or runs out of money. However, a microcontroller can hold the data
instead and have values increase and decrease for each time a recognizable card is swiped.

In addition, unlike a magnetic strip card, RFID sensor do not have to make direct physical contact
with the card and can sense a card from over and inch away.

Preparation for RFID project

Prepare the following:

- Thered PCB board with a WIFI graphic (outward waves) on it, is the sensor.

- The white card is the card.

- The blue circle attached to a keychain is the tag.

- The Arduino Uno

- Some male to female jumper wires (male to male jumper wires if you a breadboard)

1 X RFID Module

1 X RFID White card
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1 X RFID keychain

Wiring

The following table shows the needed connections between the RFID and the Arduino Uno

RFID Module Arduino UNO Development Board
Vcc sV
RST 9
GND GND
MISO 12
MOSI 11
SCK 13
NSS 10
Cautions:

On the Arduino many of the pins are not swappable. Because this device uses the SPI bus, who’s pins
cannot be moved around, pins 11, 12, 13 must remain as shown. RST and IRQ are user specified.
*This device is NOT a 5-volt powered device. You MUST power it with 3.3 volts. If you do not, you
risk overheating the RFID. Most Arduino boards include a 3.3V supply pin which can be used to
power the RFID module. RST and IRQ are user specified. The bottom pin is not being used and it still
works perfectly. (That pin is labelled as IRQ)
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RFID CODE

Download the ZIP library at:

https://www.auselectronicsdirect.com.au/arduino-rfid-uno-starter-Kit

Open the Arduino IDE and navigate to Sketch > Include Library. A drop-down menu will appear.
Click the option to “Add .ZIP Library...”

4:5' sketch_mardSa | Arduino 1.6.7

Fite Edit Sketch Tools Help

Verify/Compile CtrisR
Upload Cirlel
Upload Using Programmer  Ctri« Shifts U

Expert compiled Binary Ctit+ AR +5

Show Sketch Folder Ctel+K
aL include Libeary ' {
- AddFile... Manage Libraries...
/f pug your main code hars, ©o run ceps Add ZIP Library...

A window will open. Navigate to the location where the AddicoreRFID library you downloaded
above is currently located and open it.

Select a zip file or a folder containing the library you'd like to add
Look in: [ 4 Downloads ¥ |:|
L &
b
Recent Items
l File name: :;AddicoreRFID.zip Cpen

Desktop . — —
Files of type: | 71p files or folders v Cancel

After the library has been installed the bottom left side of the IDE should show the following
message:

You can confirm that the library has been installed by again navigating to Sketch > Include Library.
The AddicoreRFID library should now show in the list of “Contributed libraries.”

Program the Arduino

After installing the AddicoreRFID library in the steps above the library will be available to use in
sketches but any example sketches included with the library may not be shown in File > Examples
until after restarting the Arduino IDE.

1. Restart the Arduino IDE by closing all currently open Arduino IDE windows and then
opening the Arduino IDE.

2. When the Arduino IDE opens navigate to File > Examples > AddicoreRFID. Select the
“Addicore_RFID_Example” sketch. This will open a sketch which we will use with the RFID
module that we wired to our Arduino earlier.

3. Now connect your Arduino to your computer and upload the code.
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Reading RFID Tags

With your Arduino programmed with the “Addicore_RFID_Example” sketch and with it still plugged
into your computer open the serial monitor by clicking the Serial Monitor icon or pressing
CTRL+SHIFT+M.

Nolineendihg w | 9800baud

If it isn’t already selected set the serial baud rate to 9600 baud by clicking on the drop-down selection
in the lower right corner of the Serial Monitor window as shown below and selecting 9600 baud.

Once the module has read the RFID tag your Serial Monitor should show something similar to the
following:

@ COM11 (Arduine/Genuine Uno) - O X

| Send

RFID tag detected
Tag Type: Mifare One (S50)

The tag's number is: 210 , 195 , 165 , 57
Read Checlksum: 129

Calculated Checksum: 129

RFID tag detected
Tag Type: Mifaze Ons (S50)

The tag's number is: 166 , 14, 143 , 171
Read Checksum: 140

Calculated Checksum: 140

Hello Erin!

v

Autoscroll Newline ~ 9600 baud v Clear output

When the RFID reader senses a card, it starts by printing “RFID tag detected” on the Serial Monitor.
The next line verifies the card type. In normal use, this would be unnecessary. The next line prints out
the data stored in the card, in this case an ID identifying the specific tag scanned.

Note the number 6 from the screenshot above. This is the first byte of the scanned tag’s ID. The tag
you scan will have a different ID than the one used in this example. In the case of this example I will
write down 6 but you will need to write down the number preceding the first comma of the tag’s ID
number that your Serial Monitor shows. Close the Serial Monitor and find in the
Addicore_RFID_Example code the following lines of code:

// Should really check all pairs, but for n
if (str[0] == 32) £/ You
{

11 just use the first

nange this to the first byte of yo

Ser

} els

//You can change this to the first byte of w

Ser

Serial.println();
delay(1000);

Change the number in the following line of code to the number you wrote down above, in my case it
is 6.
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You can change the text on the next full line of code to whatever you want to display when you scan
the same RFID tag. | will leave mine to say, “Hello Erin!”

Upload your changed code to your Arduino, reopen the Serial Monitor, and then scan the same RFID
tag as before. Now when you scan the tag the Arduino will recognize the ID and will display the
desired text. Below is an example of what mine looks like:

RFID tag detected

Tag Type: Mifare Ome (S550)

The tag's number is: lee , 14 , 143 , 171
Read Checksum: 140

Calculated Checksum: 140

Hello Erin!

*

Make sure to keep the card close to the reader for enough time. A fast swipe by can cause
errors in the printing to the serial monitor.

The more you print to the serial monitor, the longer the card or fob has to be near it. This is
because compared to the read and write on the card, the serial monitor is slow, and bogs down
the system.

The sketch shown only validates part of the card ID number. In many systems this will be
sufficient. In others, you may want to validate more or all the ID number. In such systems,
consider checking after reading the card in a switch statement.

* Don’t forget to set the correct baud rate on the serial monitor.

Infrared Remote Control

This infrared sensor
module has three pins:
- Signal
- GND
- VCC

Wiring the Signal pin to Arduino 11. GND to GND and VCC to 5V.
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First, download the library and the code and place the library into the Arduino’s library folder. Then
upload the code to the Arduino and open the serial monitor. From here you will see "ready to decode”
and other stuff but when you press a button you will see "other button™ pop up and after a second a
number sequence will appear below it.

SPECIAL FOR MF)

Each button on the remote has a different number sequence. Press the POWER button on the remote
about 3 times and watch to see the number sequence that shows up. Then locate in the code...

case OXFFE318261B:
Serial.printin("POWER ");
break;

If you see where it says OXFFE318261B it is saying when an IR number sequence is E318261B then
serial print POWER. Now you replace E318261B with whatever you got when you pressed the power
button in the serial monitor. NEVER EVER change or mess with the OxFF, just put your number
sequence after that. Then one by one press each button and copy the number sequence that shows up
in the serial monitor after the correct OXFF.
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@' IR_MP3_Example | Arduine 1.8.4
Eile Edit Sketch Tools Help

IR_MP3_Example

receiver =

11; // pin 1 of IR receiver to Arduino digital pin 1

// create instance of 'irrecv'
/f create instance of 'decodeJre

IBRrecv irrecv(receiver):
decode_ results results;

void setupl()
{
Serial.begin (9600} ;
tln({"IR Receiver Raw Data + Button Decode Test"™):

// Start the receiver

irrecv.enakbleIRIn():

& Library Manager X
Type Al ~ | Topic Al ~ | |irremote]
IRremote by shirriff Version 2.2.3 INSTALLED (a)
Send and receive infrared signals with multiple protocols Sand and receive infrared signals with multiple protocols
More info

IRRemoteControl by Cristiano Borges

A lightweight library for send/receive infra-red signal, This library secks to be lean and intend to make it easier to send/recaive
infra-red signals. As an extra featurs, the library can read codes from flash memory.

More info

IRremoteESP8266 by Sebastien Warin, Mark Szabo, Ken Shirriff, David Conran

Send and receive infrared signals with multiple protocols (ESP8266) This library enables you to send and receive infra-red
signals on an ESPB266.

More info

MideaIRWrapper by Jeferson Lima

A library that makes, easier work with Midea Air Conditioners, Mides is a famous trademark of Air Conditioners, arround the
viorld. This library intend to make it easier, for sveryone control this air conditioner, using IRremote library as background.
More info

Close

Open the sketch and
upload to your Arduino
Development board

If this is your first remote
control project, then you
might need to import
remote control library.
Follow - Sketch | Include
Library | Manage
Libraries.

Search “irremote” in the
search bar and install the
package.

Aim the remote receiver and press the buttons and check the corresponding code for each button.
Open the Serial Monitor as the last experiment with RFID and see what are the unique code for each

button.
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